TargetTalk

A forum to talk about Olympic style shooting, rifle or pistol, 10 meters to 50 meters, and whatever is in between. Hosted by Pilkguns.com
It is currently Wed Apr 26, 2017 1:02 am

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Thu Feb 23, 2017 2:17 pm 
Offline

Joined: Tue Dec 13, 2005 12:21 pm
Posts: 17
Location: North Yarmouth, Maine
Any help or suggestion regarding problems with a relatively new left hand Anschutz Mod. 1903. It has a intermittent problem when opening the bolt after a shot is fired and the bolt does not reset the firing pin. Then the gun is in effect lock up and the bolt has to be removed and the bolt manually reset to be put back in the receiver. This happens perhaps once or twice per 10 bull target and is very awkward for the RO to have to put back in action. Don't want to send back until our winter season is over and I suppose it should go back to the importer.
Any ideas or suggestion regarding this abnormally?


Top
 Profile  
 
PostPosted: Fri Feb 24, 2017 4:39 pm 
Offline

Joined: Mon Nov 05, 2012 2:52 pm
Posts: 62
Could be a weak spring.

I would break apart the bolt and give it a good cleaning. You can replace the spring while you have the bolt apart. Its a pretty simple process.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group