TargetTalk

A forum to talk about Olympic style shooting, rifle or pistol, 10 meters to 50 meters, and whatever is in between. Hosted by Pilkguns.com
It is currently Sat Jan 20, 2018 4:03 am

All times are UTC - 6 hours [ DST ]


Forum rules


If you wish to make a donation to this forum's operation , it would be greatly appreciated.
https://www.paypal.com/paypalme/targettalk?yours=true



Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Mon Jan 01, 2018 2:12 pm 
Offline

Joined: Mon Nov 07, 2016 9:09 pm
Posts: 134
I have an early GSP that I've been using for a few years on and off. It is of the vintage that does have provision for the bolt to lock back after the last round in the magazine. It has worked this way for all the years I've had it, but suddenly has stopped working and I'm at a loss to see why. It will also not lock back on the empty magazine when opened manually - in other words it won't lock back at all. I believe the lockback is initiated by the follower button on the mags, but that is as far as my understanding goes. Can anyone point me in the right direction to troubleshoot this? Where is the mechanism located that accomplishes the lockback, and how is it otherwise manually initiated (I've never had to do that before since it has always locked back on an empty magazine).

Thanks in advance for any assistance.

Happy New Year!


Top
 Profile  
 
PostPosted: Mon Jan 01, 2018 5:37 pm 
Offline

Joined: Mon Feb 08, 2010 7:07 pm
Posts: 10
Location: Germany, Pirmasens
I believe thier is also a spring involved that is in the frame. Part 46. They get weak after some time.


Top
 Profile  
 
PostPosted: Mon Jan 01, 2018 9:55 pm 
Offline

Joined: Mon Nov 07, 2016 9:09 pm
Posts: 134
I figured it out. I'd forgotten that I'd removed the trigger assembly last time I used it, to adjust the trigger depth. When I disassembled it this afternoon to see if I could figure out what was going on, I noticed that when I'd re-inserted the trigger assembly I'd let it pinch the spring loaded lever mechanism (yes, there is a spring) that is forced up by the follower button to lock the slide open. Consequently it was jammed in the down position. I just needed to remove the trigger and (after cleaning everything thoroughly), reinstall it correctly without pinching the tip of the lever. Works perfectly now.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group