TargetTalk

A forum to talk about Olympic style shooting, rifle or pistol, 10 meters to 50 meters, and whatever is in between. Hosted by Pilkguns.com
It is currently Fri Jan 19, 2018 8:24 am

All times are UTC - 6 hours [ DST ]


Forum rules


If you wish to make a donation to this forum's operation , it would be greatly appreciated.
https://www.paypal.com/paypalme/targettalk?yours=true



Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Fri Nov 17, 2017 5:42 pm 
Offline

Joined: Wed Oct 30, 2013 9:59 am
Posts: 22
My EVO 10E will not shoot properly. I am sure the trigger is on and charged. The air cylinder is filled.

After cocking, I press the trigger and it clinks like dry fire but no air. If I pull the trigger again without recharging, it shoots.

An ideas?

Thanks


Top
 Profile  
 
PostPosted: Fri Nov 17, 2017 7:14 pm 
Offline

Joined: Tue Apr 23, 2013 5:50 pm
Posts: 243
Location: Wisconsin
I would call Scott at pilkguns.com. He services what he sells and is one of the best air pistol smiths out there.

Chip


Top
 Profile  
 
PostPosted: Fri Nov 17, 2017 7:48 pm 
Offline

Joined: Sat Sep 04, 2004 6:04 pm
Posts: 1507
Location: Massachusetts
There is typically a capacitor that gets charged up, and then that discharges into a solenoid to actuate the firing valve. It sounds like either something in the electrical process is weak enough that it takes two tries to get the valve open, or a mechanical problem that is requiring more force than the firing system can deliver on the first try.

In either case, I'm afraid you need an expert to check it out.


Top
 Profile  
 
PostPosted: Fri Nov 17, 2017 8:19 pm 
Offline

Joined: Sat Nov 15, 2008 4:20 pm
Posts: 5127
Location: Scottsdale AZ
When in doubt, reach for the BIG hammer.


Top
 Profile  
 
PostPosted: Sat Dec 09, 2017 10:35 am 
Online

Joined: Thu Aug 22, 2013 1:05 pm
Posts: 54
Location: Mesa AZ
Evo 10E
Check your battery voltage
Mine was low ( Bad Battery )
Replaced battery and it works perfect
Dennis


Top
 Profile  
 
PostPosted: Sat Dec 09, 2017 3:13 pm 
Offline

Joined: Wed Feb 13, 2013 8:56 pm
Posts: 485
Location: MInnesota
SuperIIFT wrote:
Evo 10E
Check your battery voltage
Mine was low ( Bad Battery )
Replaced battery and it works perfect
Dennis

^^ what he said

_________________
Certified Safety Instructor: Rifle & Pistol
They that give up essential liberty to obtain a little temporary safety deserve neither liberty nor safety.
~ Ben Franklin


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: 10M_Stan and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group